Wednesday, February 24, 2010

Having Metadata Export Issues with Aperture 3?

Photographers need to be aware that there are some real concerns regarding how Apple Aperture 3, is writing metadata; especially when these files are viewed by other applications in an imaging workflow.

Those using Aperture to write metadata to files that will be used with other programs at some point in their workflow need to do some testing. Those sharing images with others directly, or via the Internet may find that even basic fields like the Caption/Description and Keyword fields are not visible after exporting from Aperture 3.

You need to understand what is happening if you do additional work in Photoshop or Lightroom, and then archive your images using other programs. Otherwise you risk having some or all of your metadata disappear. This is because other programs may not see (recognize) the information you are adding to your images with Aperture 3. In addition, if you are importing images that have been worked on in other programs, some of that metadata may not be recognized or stored within Aperture.

You should really be concerned if you are fully using the various metadata fields, such as the Rights Usage Terms, Location fields, or geo-tagging your images, as many of these fields (and others), are not showing up in Photoshop, Adobe Bridge, Photo Mechanic, or Expression Media, after being exported from Aperture 3.

Visit the "Apple Aperture 3 Metadata Issues" article to find out more, including access to a chart that maps out what is seen and what is lost or hidden in JPEG, TIFF, DNG and proprietary NEF files.


John A. Visser said...

To: David Riecks,

Have you posted this to the Apple support forum for Aperture? ANy indication that Apple knows about this, and if so, if they care, or plan on doing anything about it?



David Riecks said...


I'm guessing you didn't click through to the post on the ControlledVocabulary site labeled as "Apple Aperture 3 Metadata Issues" ( above?

The most recent update was in January and notes "The Date Created field is still not appearing in images exported from Aperture, but most of the other fields that were not appearing in Adobe Bridge or Photoshop are now appearing properly. However, the Ampersand "&" character issue described below has still not been fixed and will affect any images saved as DNG files, or where the metadata is exported and saved as an XMP sidecar (.xmp file)."

The "Aperture 3 Exported Fields" (a set of online spreadsheets with results of the most recent tests" have been updated with each release.

I've not received any direct reply from Apple, but this has been noted on the Apple Support Forum by several others, including myself. As some of the issues have been fixed, I'm assuming they are aware of the issues, but if you have any contacts at Apple you may wish to bring this to their attention.